Spring Boot 2.4 版本的系统运行要求

Spring Boot 2.4.2-SNAPSHOT 版本要求至少 Java 8 及其以上版本,目前最高能够支持到 Java 15 (包含 15)的版本。 Spring 框架(Framework) 5.3.2 的版本或者以上的版本是必须的。

能够被下面的编译工具支持:

编译工具 版本
Maven 3.3+
Gradle 6 (6.3 或者后续版本)。 5.6.x 也是能够被支持的,但是已经准备开始不被兼容了。

Servlet 容器

Spring Boot 能够支持下面的嵌入 Servlet 容器版本:

名字 Servlet 版本
Tomcat 9.0 4.0
Jetty 9.4 3.1
Undertow 2.0 4.0

当然,你也可以将 Spring Boot 应用部署到任何能够兼容 3.1+ 容器版本的服务器上。

Spring-Boot-version-023

Servlet 的版本比较重要,针对不同的应用服务器版本,支持的 Servlet 的版本也是不同的。很多时候不同的 Servlet 版本之间会出现兼容性问题。

所以如果你的 Spring Boot 的版本比较高的话,如果你使用是运行容器部署方式,不是使用 Spring Boot 内置的应用服务器,你需要在这里考虑 Servlet 的版本兼容性问题。